<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML+RDFa 1.0//EN"
  "http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd">
<html lang="en" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">
<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta charset="utf-8" />
  <meta name="viewport" content="width=device-width, initial-scale=1.0" />
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.colorlines.com/sites/all/themes/cl_new/favicon.ico" type="image/vnd.microsoft.icon" />
<script>var _sf_startpt=(new Date()).getTime();</script>
<meta name="description" content="“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”" />
<meta name="news_keywords" content="cornel west, Bernie Sanders, Democratic Party, Progressive, Trump Presidency, Politics" />
<link rel="canonical" href="http://www.colorlines.com/articles/cornel-west-activists-immigrants-lets-dump-democratic-party" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="http://www.colorlines.com/node/32296" />
<meta property="og:site_name" content="Colorlines" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Cornel West to Activists, Immigrants: Let&#039;s Dump The Democratic Party" />
<meta property="og:url" content="http://www.colorlines.com/articles/cornel-west-activists-immigrants-lets-dump-democratic-party" />
<meta property="og:description" content="“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”" />
<meta property="og:updated_time" content="2017-04-24T18:08:37-04:00" />
<meta property="og:image" content="http://www.colorlines.com/sites/default/files/styles/article_lead_normal/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=L1E7JA4S" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="420" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@colorlines" />
<meta name="twitter:site" content="@Colorlines" />
<meta name="twitter:image" content="http://www.colorlines.com/sites/default/files/styles/twitter/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=YOI0Y-xJ" />
<meta name="twitter:title" content="Cornel West to Activists, Immigrants: Let&#039;s Dump The Democratic Party" />
<meta name="twitter:url" content="http://www.colorlines.com/articles/cornel-west-activists-immigrants-lets-dump-democratic-party" />
<meta name="twitter:image:width" content="800" />
<meta name="twitter:description" content="“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”" />
<meta name="twitter:image:height" content="400" />
<meta name="twitter:image:alt" content="Cornel West. Black man with salt and pepper Afro" />
<meta property="article:publisher" content="https://www.facebook.com/colorlines" />
<meta property="article:tag" content="cornel west" />
<meta property="article:tag" content="Bernie Sanders" />
<meta property="article:tag" content="Democratic Party" />
<meta property="article:tag" content="Progressive" />
<meta property="article:tag" content="Trump Presidency" />
<meta property="article:tag" content="Politics" />
<meta property="article:published_time" content="2017-04-24T17:50:14-04:00" />
<meta property="article:modified_time" content="2017-04-24T18:08:37-04:00" />
<meta itemprop="name" content="Cornel West to Activists, Immigrants: Let&#039;s Dump The Democratic Party" />
<meta itemprop="image" content="http://www.colorlines.com/sites/default/files/styles/article_lead_normal/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=L1E7JA4S" />
<meta itemprop="description" content="“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”" />
<meta name="dcterms.title" content="Cornel West to Activists, Immigrants: Let&#039;s Dump The Democratic Party" />
<meta name="dcterms.creator" content="Kenrya Rankin" />
<meta name="dcterms.description" content="“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”" />
<meta name="dcterms.date" content="2017-04-24T17:50-04:00" />
<meta name="dcterms.type" content="Text" />
<meta name="dcterms.format" content="text/html" />
<meta name="dcterms.identifier" content="http://www.colorlines.com/articles/cornel-west-activists-immigrants-lets-dump-democratic-party" />
  <title>Cornel West to Activists, Immigrants: Let's Dump The Democratic Party | Colorlines</title>
  <link type="text/css" rel="stylesheet" href="http://www.colorlines.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.colorlines.com/sites/default/files/css/css_U77z9rkroBkQHZVY5xBiLEKv7RtOUyJfAkH4JAfHY2Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.colorlines.com/sites/default/files/css/css_8WA-IiUf0y0Ebc9Su_18fgYeYjPzS2t-3vUR7rP3SrM.css" media="all" />
<link type="text/css" rel="stylesheet" href="//netdna.bootstrapcdn.com/bootstrap/3.0.2/css/bootstrap.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.colorlines.com/sites/default/files/css/css_zFzSshj2QMppy7J-wsyAyFs1kDxaguDqKGPtxOveuo8.css" media="all" />
  <!-- HTML5 element support for IE6-8 -->
  <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <script src="http://www.colorlines.com/sites/default/files/js/js_gPM6NXOQjN2XM2JWQGfy07nKmcdDFrL289YA7h80ySs.js"></script>
<script src="http://www.colorlines.com/sites/default/files/js/js_H7q2xORKmR9AN8Qx5spKEIBp7R_wG2apAswJoCUZY7I.js"></script>
<script src="//netdna.bootstrapcdn.com/bootstrap/3.0.2/js/bootstrap.min.js"></script>
<script>document.createElement( "picture" );</script>
<script src="http://www.colorlines.com/sites/default/files/js/js_EKrPKtS4_Mj-puDO3buGHy9e3THHbduMftYP358Mmn8.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-61903354-1", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);if (window.location.search.indexOf("?ref") == 0) {
	refType = window.location.search.substr(window.location.search.indexOf("?ref") +5, window.location.search.length);
	try {
		ga('send', {
			'hitType': 'event',
			'eventCategory': 'Referral Link',
			'eventAction': 'Click through',
			'eventLabel': refType,
			'page': location.href
		});
		if (window.location.search.indexOf("&") < 1) {
			history.replaceState({},"", window.location.pathname);
		}
	} catch (e) {
	}
}ga("send", "pageview");</script>
<script src="http://www.colorlines.com/sites/default/files/js/js_zMSo7bJ_u_gxPmqEvQ_IO9Qkfm-uBue9eIgCELHR_KA.js"></script>
<script src="//use.typekit.net/xdd4fmq.js"></script>
<script>try{Typekit.load();}catch(e){}</script>
<script src="http://www.colorlines.com/sites/default/files/js/js_4POjVAf7EeXLzqRBA-Jh-4_meVCoz4oq8R5DkVzNxO4.js"></script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"cl_new","theme_token":"KdnblGLtBiCEnVi9GcSSV0G3S-QR1KJHI8YqLbYTJ-I","js":{"sites\/all\/modules\/picture\/picturefill2\/picturefill.min.js":1,"sites\/all\/modules\/picture\/picture.min.js":1,"0":1,"sites\/all\/themes\/bootstrap\/js\/bootstrap.js":1,"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.10\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"\/\/netdna.bootstrapcdn.com\/bootstrap\/3.0.2\/js\/bootstrap.min.js":1,"1":1,"sites\/all\/libraries\/colorbox\/jquery.colorbox-min.js":1,"sites\/all\/modules\/popup_onload\/popup_onload.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"2":1,"sites\/all\/modules\/custom\/rf_donation\/rf_donation.js":1,"\/\/use.typekit.net\/xdd4fmq.js":1,"3":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/affix.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/alert.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/button.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/carousel.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/collapse.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/dropdown.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/modal.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/tooltip.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/popover.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/scrollspy.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/tab.js":1,"sites\/all\/themes\/cl_new\/bootstrap\/js\/transition.js":1,"sites\/all\/themes\/cl_new\/js\/readmore\/readmore.min.js":1,"sites\/all\/themes\/cl_new\/js\/scrollbar\/jquery.mCustomScrollbar.concat.min.js":1,"sites\/all\/themes\/cl_new\/js\/general.js":1,"sites\/all\/themes\/cl_new\/js\/jquery.bootstrap-autohidingnavbar.min.js":1,"sites\/all\/themes\/cl_new\/cl_colorbox\/colorbox_cl_colorbox.js":1},"css":{"modules\/system\/system.base.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/picture\/picture_wysiwyg.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/chartbeat\/chartbeat.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/popup_onload\/popup_onload-colorbox.css":1,"sites\/all\/modules\/custom\/rf_donation\/rf_donation.css":1,"\/\/netdna.bootstrapcdn.com\/bootstrap\/3.0.2\/css\/bootstrap.min.css":1,"sites\/all\/themes\/bootstrap\/css\/overrides.css":1,"sites\/all\/themes\/cl_new\/less\/style.less":1,"sites\/all\/themes\/cl_new\/js\/scrollbar\/jquery.mCustomScrollbar.css":1,"sites\/all\/themes\/cl_new\/cl_colorbox\/colorbox_cl_colorbox.css":1}},"chartbeat":{"uid":9488,"domain":"www.colorlines.com","useCanonical":true,"noCookies":true},"popup_onload":{"html":"\u003Cdiv class=\u0022entity entity-popup-onload popup-onload-popup-onload-basic clearfix\u0022\u003E\n\n  \n  \u003Cdiv class=\u0022content\u0022\u003E\n    \u003Cdiv class=\u0022field field-name-field-fake-body field-type-text field-label-hidden\u0022\u003E\u003Cdiv class=\u0022field-items\u0022\u003E\u003Cdiv class=\u0022field-item even\u0022\u003E\u003Cdiv\u003E\u003Ca class=\u0022donate-button\u0022 href=\u0022https:\/\/www.colorlines.com\/donate\/2017springpop\u0022\u003E\u003Cimg alt=\u0022 Two arms raised, clasped at hands amidst text on twining banner. Lines of purple flowers flow outward in background.\u0022 src=\u0022\/sites\/default\/files\/ColorlinesSpringFundraiserGraphic_PopUpImage3SM.jpg\u0022 width=\u0022300px\u0022 \/\u003E\u003C\/a\u003E\u003C\/div\u003E\n\u003C\/div\u003E\u003C\/div\u003E\u003C\/div\u003E  \u003C\/div\u003E\n\u003C\/div\u003E\n","delay":"5000","fixed":true,"popup_id":"1","className":"popup_onload","close":"","cookieName":"popup_onload_time","cookieLifetime":"86400"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"urlIsAjaxTrusted":{"\/articles\/cornel-west-activists-immigrants-lets-dump-democratic-party":true},"bootstrap":{"anchorsFix":1,"anchorsSmoothScrolling":1,"popoverEnabled":1,"popoverOptions":{"animation":1,"html":0,"placement":"right","selector":"","trigger":"click","title":"","content":"","delay":0,"container":"body"},"tooltipEnabled":1,"tooltipOptions":{"animation":1,"html":0,"placement":"auto left","selector":"","trigger":"hover focus","delay":0,"container":"body"}}});</script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-32296 node-type-article navbar-is-fixed-top" >
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <header id="navbar" role="banner" class="hidebar navbar navbar-fixed-top navbar-default">
  <div class="container">
    <div class="navbar-header">
      <!-- .btn-navbar is used as the toggle for collapsed navbar content -->
      <div class="header-divider menu-button-box col-sm-1 col-xs-2">
      <button type="button" class="hidebar-toggle">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="menu-name hidden-xs visible-sm visible-md  visible-lg">
        	Menu
        </span>
      </button>
      </div>
      
      <div class="name-brand header-divider col-md-8 col-sm-11 col-xs-10">
          <div class="col-xs-8 header-divider header-logo-container"><a class="name navbar-brand" href="/" title="Home"><img class="header-logo" src="/sites/all/themes/cl_new/images/colorlines_on_white.png" alt="Colorlines"/></a></div>
          <div class="published-by col-xs-4">
          <div>Published by <br /><a href="https://www.raceforward.org" class="external"><img src="/sites/all/themes/cl_new/images/race_forward_micro_black.png" alt="Race Forward" /></a></div></div>
	    </div>
	  <div class="social-media-links header-divider hidden-sm hidden-xs col-md-1"><a href="https://instagram.com/colorlinesnews" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-instagram.svg" alt="Follow us on Instagram" /></a><a href="https://www.facebook.com/colorlines" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-facebook.svg" alt="Like us on Facebook" /></a><a href="https://twitter.com/colorlines" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-twitter.svg" alt="Follow us on Twitter" /></a>
	  <br />Connect</div>
	  <div class="donate-link header-divider hidden-sm hidden-xs col-md-1"><a href="https://www.colorlines.com/donate" class="external"><img src="/sites/all/themes/cl_new/images/icons/donate.svg" alt="small credit card with heart" /><br />Donate</a></div>
	  <div class="subscribe-link header-divider hidden-sm hidden-xs col-md-1"><a href="https://www.colorlines.com/getemails"><img src="/sites/all/themes/cl_new/images/icons/subscribe.svg" alt="email icon" /><br />Subscribe</a></div>
	 <div class="hot-search">
	           <nav role="navigation" class="col-sm-10 col-xs-12 hot-nav">
          	<div class="hot-topics-label hidden-xs col-md-2">Hot Topics</div>
              <div class="region region-navigation">
    <section id="block-views-topics-menu-new-block-1" class="block block-views clearfix">

      
  <div class="view view-topics-menu-new view-id-topics_menu_new view-display-id-block_1 view-dom-id-350f58696466baab6a8751aff20ff320">
        
  
  
      <div class="view-content">
      <div class="hot">    <ul>          <li class="cl-term cl-0">  
          <a href="/categories/arts-culture">Arts &amp; Culture</a>  </li>
          <li class="cl-term cl-1">  
          <a href="/categories/trump-presidency">Trump Presidency</a>  </li>
          <li class="cl-term cl-2">  
          <a href="/tags/islamophobia">Islamophobia</a>  </li>
          <li class="cl-term cl-3">  
          <a href="/categories/police-violence">Police Violence</a>  </li>
          <li class="cl-term cl-4">  
          <a href="/categories/gender-sexuality">Gender &amp; Sexuality</a>  </li>
      </ul></div>    </div>
  
  
  
  
  
  
</div>
</section> <!-- /.block -->
  </div>
        </nav>
	  	  	  <div class="search-container col-xs-12 col-sm-12 col-md-2">
	  	  <div class="region region-search">
    <section id="block-search-form" class="block block-search clearfix">

      
  <form class="form-search content-search" action="/articles/cornel-west-activists-immigrants-lets-dump-democratic-party" method="post" id="search-block-form" accept-charset="UTF-8"><div><div>
      <h2 class="element-invisible">Search form</h2>
    <div class="input-group"><input title="Enter the terms you wish to search for." placeholder="SEARCH" class="form-control form-text" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" /><span class="input-group-btn"><button type="submit" class="btn btn-default"><i class="icon glyphicon glyphicon-search" aria-hidden="true"></i></button></span></div><button class="element-invisible btn btn-primary form-submit" id="edit-submit" name="op" value="Search" type="submit">Search</button>
<input type="hidden" name="form_build_id" value="form-DL1-rGxJ59qVdTYvzVcBOVAB6IsjEgnE9l2Pu9cEXFU" />
<input type="hidden" name="form_id" value="search_block_form" />
<input type="hidden" name="solrsort" value="ds_created desc" />
</div>
</div></form>
</section> <!-- /.block -->
  </div>
	  </div>
	  	  </div>
    </div>
  </div>
</header>
<div class="main-container container">

  <header role="banner" id="page-header">
    
      </header> <!-- /#page-header -->
	<div class="hidden-sidebar sidebar-hidden">
		<div class="inner-sidebar">
			<!--<div id="close-menu">Close Menu</div>-->
			<nav role="navigation">
				<a href="/" alt="Home">Home</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/user/login" alt="Sign In">Sign In</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/user/login" alt="Create Account">Create Account</a>			</nav>
			<div class="social-media"><a href="https://instagram.com/colorlinesnews" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-instagram.svg" alt="Follow us on Instagram" /></a><a href="https://www.facebook.com/colorlines" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-facebook.svg" alt="Like us on Facebook" /></a><a href="https://twitter.com/colorlines" class="external"><img src="/sites/all/themes/cl_new/images/icons/link-twitter.svg" alt="Follow us on Twitter" /></a><br />Connect</div>
			 <div class="donate"><a href="/donate" class="external"><img src="/sites/all/themes/cl_new/images/icons/donate.svg" alt="small credit card with heart" /><br />Donate</a></div>
			  <div class="subscribe"><a href="/getemails"><img src="/sites/all/themes/cl_new/images/icons/subscribe.svg" alt="email icon" /><br />Subscribe</a></div>
			  
			  <div class="search-link hidden-search col-xs-2">
				  <img src="/sites/all/themes/cl_new/images/icons/search.svg" title="search" alt="Small magnifying glass" />
				  Search
			  </div>
			  <div class="region region-hidebar">
    <section id="block-views-ongoing-topics-block" class="block block-views clearfix">

        <h2 class="block-title">Ongoing Topics</h2>
    
  <div class="view view-ongoing-topics view-id-ongoing_topics view-display-id-block view-dom-id-19f7fad15c6ac5eafa303ec32a122b7d">
        
  
  
      <div class="view-content">
          <ul>          <li class="">  
          <a href="/categories/arts-culture">Arts &amp; Culture</a>  </li>
          <li class="">  
          <a href="/categories/criminal-justice">Criminal Justice</a>  </li>
          <li class="">  
          <a href="/categories/economic-justice">Economic Justice</a>  </li>
          <li class="">  
          <a href="/categories/economy">Economy</a>  </li>
          <li class="">  
          <a href="/categories/environment">Environment</a>  </li>
          <li class="">  
          <a href="/categories/gender-sexuality">Gender &amp; Sexuality</a>  </li>
          <li class="">  
          <a href="/categories/global-affairs">Global Affairs</a>  </li>
          <li class="">  
          <a href="/categories/health">Health</a>  </li>
          <li class="">  
          <a href="/categories/history">History</a>  </li>
          <li class="">  
          <a href="/categories/immigration">Immigration</a>  </li>
          <li class="">  
          <a href="/categories/labor">Labor</a>  </li>
          <li class="">  
          <a href="/categories/media">Media</a>  </li>
          <li class="">  
          <a href="/categories/national-security">National Security</a>  </li>
          <li class="">  
          <a href="/categories/native-affairs">Native Affairs</a>  </li>
          <li class="">  
          <a href="/categories/politics">Politics</a>  </li>
          <li class="">  
          <a href="/categories/schools-youth">Schools &amp; Youth</a>  </li>
          <li class="">  
          <a href="/categories/sports">Sports</a>  </li>
      </ul>    </div>
  
  
  
  
  
  
</div>
</section> <!-- /.block -->
  </div>
		</div>
	</div>
  <div class="row hidebar hidebar-support">

    
    <section class="col-sm-12">
                  <a id="main-content"></a>
                  	<div class="article-title col-sm-6 col-sm-offset-3 col-xs-10 col-xs-offset-1">
			<h1 class="page-header">Cornel West to Activists, Immigrants: Let&#039;s Dump The Democratic Party</h1>
			<div class="subheading"><p>“If a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance.”</p>
</div>
      	</div>
                  <div class="col-sm-6 col-sm-offset-3 col-xs-10 col-xs-offset-1">
            </div>
                                        <div class="region region-content">
    <section id="block-system-main" class="block block-system clearfix">

      
  <div id="node-32296" class="node node-article node-promoted node-sticky clearfix">

  
        <div>
	  <div class="article-meta col-sm-6 col-sm-offset-3 col-xs-10 col-xs-offset-1">
		<span class="author-line"><a href="/writers/kenrya-rankin">Kenrya Rankin</a></span> 
		<span class="publish-date-time">&nbsp;<span class="date">Apr 24, 2017</span> <span class="time">5:50PM EDT</span></span>
	   </div>
   </div>
   <div class="primary-image col-sm-6 col-sm-offset-3 col-xs-10 col-xs-offset-1">
   					<picture  title="Dr. Cornel West speaks onstage during the &#039;Black America Since MLK: And Still I Rise&#039; panel discussion at the PBS portion of the 2016 Television Critics Association Summer Tour at The Beverly Hilton Hotel on July 29, 2016, in Beverly Hills, California.">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/article_lead_normal/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=L1E7JA4S&amp;timestamp=1493071165 1x" media="(min-width:1200px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/article_lead_normal/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=L1E7JA4S&amp;timestamp=1493071165 1x" media="(min-width:992px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/article_lead_normal/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=L1E7JA4S&amp;timestamp=1493071165 1x" media="(min-width:768px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/article_lead_mobile/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=HaAWpkav&amp;timestamp=1493071165 1x" media="(min-width:480px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/embedded_image/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=cct1tll3&amp;timestamp=1493071165 1x" media="(max-width:479px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/embedded_image/public/images/articles/2017/04/cornel-west-dump-democrats-4-24-17.jpg?itok=cct1tll3&amp;timestamp=1493071165" alt="Cornel West. Black man with salt and pepper Afro" title="Dr. Cornel West speaks onstage during the &#039;Black America Since MLK: And Still I Rise&#039; panel discussion at the PBS portion of the 2016 Television Critics Association Summer Tour at The Beverly Hilton Hotel on July 29, 2016, in Beverly Hills, California." />
</picture>					<div class="article-mediacredit">
				<span class="image-caption">Dr. Cornel West speaks onstage during the "Black America Since MLK: And Still I Rise" panel discussion at the PBS portion of the 2016 Television Critics Association Summer Tour at The Beverly Hilton Hotel on July 29, 2016, in Beverly Hills, California.</span> <br /><span class="image-type">Photo: </span> <span class="image-credit">Frederick M. Brown/Getty Images</span>			</div>
				</div>
      <div class="article-content col-sm-9 col-xs-12">
      
            <div class="col-sm-4 share-this" role="complementary">
      	 <section id="block-cl-share-cl-share" class="block block-cl-share clearfix">

      
  	<p class="h2">Share</p>
	<div class="social-icons">
		<div class="social-block">
			<!--<a href="mailto://?from=&subject=" class="email-share" title="Share via Email"><span class="email-link">&nbsp;</span></a>
			<span class="social-count">&nbsp;</span>-->
		</div>
		<!--<a class="social-share" title="Share on Instagram"><span class="instagram-link">&nbsp;</span></a>-->
		<div class="social-block">
			<a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.colorlines.com%2Farticles%2Fcornel-west-activists-immigrants-lets-dump-democratic-party" class="social-share facebook" rel="nofollow" title="Share on Facebook"><span class="facebook-link">&nbsp;</span></a>
					</div>
		<div class="social-block">
			<a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.colorlines.com%2Farticles%2Fcornel-west-activists-immigrants-lets-dump-democratic-party&via=colorlines" class="social-share twitter" title="Tweet this"><span class="twitter-link" rel="nofollow">&nbsp;</span></a>
					</div>
			</div>
	
</section> <!-- /.block -->
<section id="block-block-1" class="block block-block clearfix">

      
  <p> </p>

</section> <!-- /.block -->
      </div>
            <div class="article-body col-sm-8 col-xs-12">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><p>Professor and author <a href="http://www.colorlines.com/tags/cornel-west-0" target="_blank">Dr. Cornel West</a> has a message for people who identify themselves as political and social progressives: “The neoliberal vision of the Democratic party has run its course.”</p>
<p>In an <a href="https://www.theguardian.com/commentisfree/2017/apr/24/democrats-delivered-one-thing-100-days-disappointment" target="_blank">essay</a> published by The Guardian today (April 24), West argues that the first 100 days of President <a href="http://www.colorlines.com/tags/donald-trump" target="_blank">Donald Trump</a>’s term in office makes it clear that the Democratic party is not capable of leading progressives in a time when the GOP dominates the American political landscape.</p>
<blockquote><p>The corporate wing has made it clear that the populist wing has little power or place in its future. The discipline of the party is strong on self-preservation and weak on embracing new voices. And party leaders too often revel in self-righteousness and self-pity rather than self-criticism and self-enhancement. The time has come to bid farewell to a moribund party that lacks imagination, courage and gusto. …</p>
<p>We progressives need new leadership and institutional capacity that provides strong resistance to Trump’s vicious policies, concrete alternatives that matter to ordinary citizens and credible visions that go beyond Wall Street priorities and militaristic policies. And appealing to young people is a good testing ground.</p>
</blockquote>
<p>A group of former Bernie Sanders staffers have <a href="https://draftbernie.org/" target="_blank">come together</a> to convince Sanders to head a new “people’s party,” and West makes an appeal to immigrants, activists and progressive leaders to join the ranks:</p>
<blockquote><p>And if a class-conscious multi-racial party attuned to anti-sexist, anti-homophobic and anti-militaristic issues and grounded in ecological commitments can reconfigure our citizenship, maybe our decaying democracy has a chance. And if brother Bernie Sanders decides to join us—with many others, including sister Jill Stein and activists from Black Lives Matter and Brown immigrant groups and Standing Rock freedom fighters and betrayed working people—we may build something for the near future after Trump implodes.</p>
</blockquote>
<p>Read the full essay <a href="https://www.theguardian.com/commentisfree/2017/apr/24/democrats-delivered-one-thing-100-days-disappointment" target="_blank">here</a>.</p>
</div></div></div>            <div class="article-tags">
      <div class="field field-name-field-cl-tag field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/tags/cornel-west-0">cornel west</a></div><div class="field-item odd"><a href="/tags/bernie-sanders">Bernie Sanders</a></div><div class="field-item even"><a href="/tags/democratic-party">Democratic Party</a></div><div class="field-item odd"><a href="/tags/progressive">Progressive</a></div><div class="field-item even"><a href="/tags/trump-presidency">Trump Presidency</a></div><div class="field-item odd"><a href="/tags/politics-0">Politics</a></div></div></div>      </div>
      <hr class="divider" />
	  <ul class="links list-inline"><li class="comment_forbidden first last"></li>
</ul>      <div class="clearfix"></div>
      </div>
      </div>
            <aside class="col-sm-3" role="complementary">
      	 <section id="block-views-front-page-banners-block-1" class="block block-views clearfix">

      
  <div class="view view-front-page-banners view-id-front_page_banners view-display-id-block_1 view-dom-id-f798c2efe8c972a3b4bbd4f75a07a3e1">
        
  
  
      <div class="view-content">
        <a href="https://www.colorlines.com/donate/2017springside">
	<picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31786-2017-spring-fundraising.jpg?itok=NB3l6l8K&amp;timestamp=1491350524 1x" media="(min-width:1200px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31786-2017-spring-fundraising.jpg?itok=NB3l6l8K&amp;timestamp=1491350524 1x" media="(min-width:992px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31786-2017-spring-fundraising.jpg?itok=NB3l6l8K&amp;timestamp=1491350524 1x" media="(min-width:768px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_700/public/images/banners/31786-2017-spring-fundraising.jpg?itok=3c08rqHl&amp;timestamp=1491350524 1x" media="(min-width:480px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31786-2017-spring-fundraising.jpg?itok=NB3l6l8K&amp;timestamp=1491350524 1x" media="(max-width:479px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31786-2017-spring-fundraising.jpg?itok=NB3l6l8K&amp;timestamp=1491350524" alt="Text: Support Colorlines. Let&#039;s be stronger together. Image: Two arms raised, clasped at hands amidst text on twining banner. Lines of purple flowers flow outward in background." title="" />
</picture></a>    </div>
  
  
  
  
  
  
</div>
</section> <!-- /.block -->
<section id="block-apachesolr-search-mlt-002" class="block block-apachesolr-search clearfix">

        <h2 class="block-title">Related Articles</h2>
    
  <div class="view view-related-articles view-id-related_articles view-display-id-solr_mlt section-block view-dom-id-bc84fedd4aeeabb90f13edc457d0c0ad">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
    	<div class="related entry-content">
						<div class="entry-img">
			<div class="field-content"><a href="/articles/4-key-takeaways-bernie-sanders-post-election-interview"><picture  title="U.S. Senator Bernie Sanders (I-VT) speaks during campaign rally with Democratic presidential nominee Hillary Clinton at Coastal Credit Union Music Park at Walnut Creek on November 3, 2016, in Raleigh, North Carolina.">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/articles/2016/11/bernie-sanders-post-election-11-10-16.jpg?itok=FpzH-1Js&amp;timestamp=1478812191 1x" media="(min-width:480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/articles/2016/11/bernie-sanders-post-election-11-10-16.jpg?itok=FpzH-1Js&amp;timestamp=1478812191" alt="Bernie Sanders stands behind a podium with &quot;Stronger Together&quot; sign" title="U.S. Senator Bernie Sanders (I-VT) speaks during campaign rally with Democratic presidential nominee Hillary Clinton at Coastal Credit Union Music Park at Walnut Creek on November 3, 2016, in Raleigh, North Carolina." />
</picture></a></div>		</div>
				<p class="title">
			<span class="field-content"><a href="/articles/4-key-takeaways-bernie-sanders-post-election-interview">4 Key Takeaways From Bernie Sanders&#039; Post-Election Interview</a></span>		</p>
	</div>
  </div>
  <div class="views-row views-row-2 views-row-even">
    	<div class="related entry-content">
						<div class="entry-img">
			<div class="field-content"><a href="/articles/demsinphilly-bernie-sanders-supporters-explain-why-theyre-standing-their-man"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/articles/2016/07/bernie-sanders-protest-dnc-now-072516.JPG?itok=MSyA0tKD&amp;timestamp=1469485953 1x" media="(min-width:480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/articles/2016/07/bernie-sanders-protest-dnc-now-072516.JPG?itok=MSyA0tKD&amp;timestamp=1469485953" alt="Bernie Sanders supporters holding blue signs with white text" title="" />
</picture></a></div>		</div>
				<p class="title">
			<span class="field-content"><a href="/articles/demsinphilly-bernie-sanders-supporters-explain-why-theyre-standing-their-man">#DemsInPhilly: Bernie Sanders&#039; Supporters Explain Why They&#039;re Standing by Their Man</a></span>		</p>
	</div>
  </div>
  <div class="views-row views-row-3 views-row-odd">
    	<div class="related entry-content">
						<div class="entry-img">
			<div class="field-content"><a href="/articles/bernie-sanders-kicks-hbcu-tour-today"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2016/01/Bernie%20Sanders%20for%20NOW%20011416.jpg?itok=i3q03H28&amp;timestamp=1452800957 1x" media="(min-width:480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2016/01/Bernie%20Sanders%20for%20NOW%20011416.jpg?itok=i3q03H28&amp;timestamp=1452800957" alt="" title="" />
</picture></a></div>		</div>
				<p class="title">
			<span class="field-content"><a href="/articles/bernie-sanders-kicks-hbcu-tour-today">Bernie Sanders Kicks off HBCU Tour Today</a></span>		</p>
	</div>
  </div>
  <div class="views-row views-row-4 views-row-even">
    	<div class="related entry-content">
						<div class="entry-img">
			<div class="field-content"><a href="/articles/read-black-lives-matter-activists-say-they-arent-endorsing-political-candidates"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2015/08/Colorlines%20Screenshot%20of%20Black%20Lives%20Matter%20Protesters%20at%20Bernie%20Sanders%20Rally%20for%20NOW%20Post%20081015.png?itok=gvyD5Zqe&amp;timestamp=1439242169 1x" media="(min-width:480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2015/08/Colorlines%20Screenshot%20of%20Black%20Lives%20Matter%20Protesters%20at%20Bernie%20Sanders%20Rally%20for%20NOW%20Post%20081015.png?itok=gvyD5Zqe&amp;timestamp=1439242169" alt="" title="" />
</picture></a></div>		</div>
				<p class="title">
			<span class="field-content"><a href="/articles/read-black-lives-matter-activists-say-they-arent-endorsing-political-candidates">READ: Black Lives Matter Activists Say They Aren&#039;t Endorsing Political Candidates</a></span>		</p>
	</div>
  </div>
  <div class="views-row views-row-5 views-row-odd views-row-last">
    	<div class="related entry-content">
						<div class="entry-img">
			<div class="field-content"><a href="/articles/killer-mike-endorses-bernie-sanders-prez"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2015/06/Killer%20Mike%20for%20NOW%20Post%20063015.jpg?itok=AyNxp37_&amp;timestamp=1435692032 1x" media="(min-width:480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/teaser_thumb/public/images/2015/06/Killer%20Mike%20for%20NOW%20Post%20063015.jpg?itok=AyNxp37_&amp;timestamp=1435692032" alt="" title="" />
</picture></a></div>		</div>
				<p class="title">
			<span class="field-content"><a href="/articles/killer-mike-endorses-bernie-sanders-prez">Killer Mike Endorses Bernie Sanders for Prez</a></span>		</p>
	</div>
  </div>
    </div>
  
  
  
  
  
  
</div>
</section> <!-- /.block -->
<section id="block-views-front-page-banners-block-2" class="block block-views clearfix">

      
  <div class="view view-front-page-banners view-id-front_page_banners view-display-id-block_2 view-dom-id-2fd5404cd050005abc64e0be060e10ed">
        
  
  
      <div class="view-content">
        <a href="https://facingrace.raceforward.org">
	<picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31466-facing-race-2018-top.jpg?itok=HuSpdl1g&amp;timestamp=1490373448 1x" media="(min-width:1200px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31466-facing-race-2018-top.jpg?itok=HuSpdl1g&amp;timestamp=1490373448 1x" media="(min-width:992px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31466-facing-race-2018-top.jpg?itok=HuSpdl1g&amp;timestamp=1490373448 1x" media="(min-width:768px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_700/public/images/banners/31466-facing-race-2018-top.jpg?itok=osmVgwj3&amp;timestamp=1490373448 1x" media="(min-width:480px)" />
<source srcset="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31466-facing-race-2018-top.jpg?itok=HuSpdl1g&amp;timestamp=1490373448 1x" media="(max-width:479px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.colorlines.com/sites/default/files/styles/banner_380/public/images/banners/31466-facing-race-2018-top.jpg?itok=HuSpdl1g&amp;timestamp=1490373448" alt="Background: Line drawings of fist, elevated train, buildings, and flowers. Text: Facing Race. November 8-10, 2018. Presented by Race Forward. Learn More." title="" />
</picture></a>    </div>
  
  
  
  
  
  
</div>
</section> <!-- /.block -->
      </aside>
        <!--<div class="article-tags"><div class="field field-name-field-cl-tag field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/tags/cornel-west-0">cornel west</a></div><div class="field-item odd"><a href="/tags/bernie-sanders">Bernie Sanders</a></div><div class="field-item even"><a href="/tags/democratic-party">Democratic Party</a></div><div class="field-item odd"><a href="/tags/progressive">Progressive</a></div><div class="field-item even"><a href="/tags/trump-presidency">Trump Presidency</a></div><div class="field-item odd"><a href="/tags/politics-0">Politics</a></div></div></div></div>-->

</div>

</section> <!-- /.block -->
  </div>
    </section>

    
  </div>
</div>
</div><!-- /.main-container /.container -->
<footer class="footer hidebar">
	<div class="container">
		<div class="row">
				

			<div class="footer-element statement col-md-5 col-sm-9 col-xs-12">
				<p><img class="text-logo" src="/sites/all/themes/cl_new/images/colorlines_on_black.png" alt="Colorlines"/> is a daily news site where race matters, featuring award-winning investigative reporting and news analysis.</p>
				<p><img class="text-logo" src="/sites/all/themes/cl_new/images/colorlines_on_black.png" alt="Colorlines"/> is published by <a href="https://www.raceforward.org" class="external">Race Forward</a>, a national organization that advances racial justice through research, media and practice.</p>
			</div>

			<div class="footer-element footer-links col-md-2 col-sm-3 col-xs-12">
				<ul>
			        <li><a href="/staff">Masthead</a></li>
			        <li><a href="/contact">Contact</a></li>
			        <li><a href="/submissions">Submissions</a></li>
			        <li><a href="/press">Press</a></li>
			        <li><a href="/privacy">Privacy</a></li>
			        <li class="ToS"><a href="/terms">Terms of Service</a></li>
			    </ul>
			</div>

			<div class="footer-element copyright col-md-5 col-sm-12 col-xs-12">
			    <p class="copyright-line"><span>©&nbsp;<img class="footer-logo" src="/sites/all/themes/cl_new/images/colorlines_on_black.png" alt="Colorlines"/> 2015</p>
			    <p class="footer-donate sub-copyright col-xs-6">
			    	<a href="https://www.colorlines.com/donate" class="external"><img src="/sites/all/themes/cl_new/images/icons/donate.svg" alt="small credit card with heart" /><br />
			    	Donate</a>
			    </p>
			    <p class="footer-subscribe sub-copyright col-xs-6">
			    	<a href="https://www.colorlines.com/getemails"><img src="/sites/all/themes/cl_new/images/icons/subscribe.svg" alt="email icon" /><br />Subscribe</a>
			    </p>
			</div>

		</div>
	</div>
</footer>
    <div class="region region-page-bottom">
    <script type="text/javascript">
  var _sf_async_config=Drupal.settings.chartbeat;
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src',
         (("https:" == document.location.protocol) ? "https://s3.amazonaws.com/" : "http://") +
         "static.chartbeat.com/js/chartbeat.js");
      document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
       loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script>  </div>
<script src="http://www.colorlines.com/sites/default/files/js/js_7Ukqb3ierdBEL0eowfOKzTkNu-Le97OPm-UqTS5NENU.js"></script>
<script>/*<![CDATA[*/(function(w,a,b,d,s){w[a]=w[a]||{};w[a][b]=w[a][b]||{q:[],track:function(r,e,t){this.q.push({r:r,e:e,t:t||+new Date});}};var e=d.createElement(s);var f=d.getElementsByTagName(s)[0];e.async=1;e.src='//act.colorlines.com/cdnr/58/acton/bn/tracker/1069';f.parentNode.insertBefore(e,f);})(window,'ActOn','Beacon',document,'script');ActOn.Beacon.track();/*]]>*/</script>
<script src="http://www.colorlines.com/sites/default/files/js/js_KtMRViuj0KwtbGPfyAKBS7VWEusTIlDLn8dwDl84ACg.js"></script>
</body>
</html>
